Roger Lewinton

Roger Lewinton

Guest

Rogerlewinton@gmail.com

  MXA042 Basic Flame Detector (216 views)

Apr 9, 2020 21:45

I have the MXA042 flame detector and I've had it working. Then unfortunatly the TR4 transister died and with help fro your support staff I sourced and replaced the failed tranistor. It then worked for another week. But now it has stopped detecting any flame. I am no longer am able to detect a voltage across the flame sensor probe points.

The transisters seem to check OK, if you have any suggestions what to look for or do I send it back for free repair under the 90day warranty.
https://www.thaikits.com/index.php/terms-of-sale.html

82.47.17.116

Roger Lewinton

Roger Lewinton

Guest

Rogerlewinton@gmail.com

Admin_support

Admin_support

Admin

hobby@futurekit.com

Apr 10, 2020 08:12 #1

Please check all transistors and taking pictures of the circuit below and above then send to us. So that we may conduct a preliminary examination.

171.96.75.98

Admin_support

Admin_support

Admin

hobby@futurekit.com

Julius Tomsits

Julius Tomsits

Guest

odyssey@mindspring.com

May 9, 2020 21:33 #2

I have the same board. Everything was connected and working on a clean 12V supply. After 15 minutes of positive flame detection the board stopped detecting flame. I purchase the board through on of your venders but they are not being cooperative. I sent the board along with documentation of the test circuit back to them but no response. Now I'm out a board and no replacment. I purchased another board because I needed to get this project up and running. That board has run flawlessly for well over 48 hours. How can I obtain a replacement for the defective board?

96.83.7.74

Julius Tomsits

Julius Tomsits

Guest

odyssey@mindspring.com

Post reply
CAPTCHA Image
Please fill in your result.